psb.jpg

1.使用思科路由器与ISP相连,光纤接入。

2.内部网络使用3560三层交换机,下接2交换机,分别划分VLAN10和VLAN20。

3.VLAN通过路由NAT上网。

设计思考:

1、  路由器上配置NAT转换,默认路由至ISP,静态路由至三层交换机。

2、  三层交换机上划VLAN,实现VLAN间路由,至路由器默认路由。

AllenSW2交换机配置

Switch>enable

Switch#configure terminal

Switch(config)#hostname AllenSW2    交换机命名为AllenSW2


AllenSW2#vlan database    进入vlan配置模式

AllenSW2(vlan)#vlan 10      创建VLAN10


AllenSW2(config)#interface range fastEthernet 0/1-23      进入端口1-23

AllenSW2(config-if-range)#switchport mode access          接口为access模式,即接入端口

AllenSW2(config-if-range)#switchport access vlan 10       端口加入vlan10

AllenSW2(config)#interface fastEthernet 0/24                   进入端口24

AllenSW2(config-if)#switchport mode trunk                       设置端口的中继模式为trunk


AllenSW3交换机配置

Switch>enable

Switch#configure terminal

Switch(config)#hostname AllenSW3    交换机命名为AllenSW3


AllenSW3#vlan database    进入vlan配置模式

AllenSW3(vlan)#vlan 20      创建VLAN20


AllenSW3(config)#interface range fastEthernet 0/1-23   进入端口1-23

AllenSW3(config-if-range)#switchport mode access       接口为access模式,即接入端口

AllenSW3(config-if-range)#switchport access vlan 20    端口加入vlan20

AllenSW3(config)#interface fastEthernet 0/24                进入端口24

AllenSW3(config-if)#switchport mode trunk                    设置端口的中继模式为trunk


Alle3SW4三层交换机配置

Switch>enable

Switch#configure terminal

Switch(config)#hostname Allen3SW4  三层交换机命名为Allen3SW4


Allen3SW4#vlan database    进入vlan配置模式

Allen3SW4(vlan)#vlan 10      创建VLAN10

Allen3SW4#vlan database    进入vlan配置模式

Allen3SW4(vlan)#vlan 20      创建VLAN20


三层交换机支持各VLAN之间的路由相当于单臂路由上子接口配置的IP地址

Allen3SW4(config)#interface vlan 10

Allen3SW4(config-if)#ip address 192.168.10.10 255.255.255.0

Allen3SW4(config)#interface vlan 20

Allen3SW4(config-if)#ip address 192.168.20.10 255.255.255.0


Allen3SW4(config)#interface fa0/3    进入fast3号端口

Allen3SW4(config-if)#switchport trunk encapsulation dot1q    设置端口中继协议为802.1q

Allen3SW4(config-if)#switchport mode trunk    设置端口的中继模式为trunk

Allen3SW4(config-if)#switchport trunk allowed vlan all    允许所有VLAN经过此中继传输


Allen3SW4(config)#interface fa0/4    进入fast4号端口

Allen3SW4(config-if)#switchport trunk encapsulation dot1q    设置端口中继协议为802.1q

Allen3SW4(config-if)#switchport mode trunk    设置端口的中继模式为trunk

Allen3SW4(config-if)#switchport trunk allowed vlan all    允许所有VLAN经过此中继传输


此时AllenPC1能ping通三层交换机VLAN 10的IP:192.168.10.10,无法ping通AllenPC2的IP:192.168.20.9

1.jpg

2.jpg

此时AllenPC2能ping通三层交换机VLAN 20的IP:192.168.20.10,无法ping通AllenPC1的IP:192.168.10.9

3.jpg

4.jpg

进入三层交换机

Allen3SW4(config)#ip routing

启动三层交换机的路由功能,即可实现不同VLAN间互访,如果不开启路由功能就不能使用路由协议

AllenPC1与AllenPC2必须分别设置VLAN10和VLAN20地址为网关地址

AllenPC1与AllenPC2互通

5.jpg

6.jpg

Allen3SW4(config)#interface fa0/1                                            进入fast1号端口

Allen3SW4(config-if)#no switchport                                           使三层交换机端口fa 0/1具有路由功能

Allen3SW4(config-if)#ip address 192.168.0.2 255.255.255.0    设置路由口的IP地址

Allen3SW4(config-if)#no shutdwon


Allen3SW4(config)#router rip                                 启用路由协议RIP

Allen3SW4(config-router)#version 2                      使用的是RIPv2,如果没有这句,则是使用RIPv1

Allen3SW4(config-router)#no auto-summary

Allen3SW4(config-router)#network 192.168.10.0   宣告直连的网段

Allen3SW4(config-router)#network 192.168.20.0   宣告直连的网段

Allen3SW4(config-router)#network 192.168.0.0     宣告直连的网段


路由器配置

Router>en

Router#configure terminal

Router(config)#hostname AllenRouter


AllenRouter(config)#interface gigabitEthernet 0/0

AllenRouter(config-if)#ip address 192.168.0.1 255.255.255.0

AllenRouter(config-if)#ip nat inside

AllenRouter(config-if)#no shutdown

此时AllenPC1与AllenPC2均可以Ping通三层交换机fa0/1端口IP:192.168.0.2,但无法Ping通路由器内网IP:192.168.0.1


AllenRouter(config)#interface gigabitEthernet 0/1

AllenRouter(config-if)#ip address 58.216.224.165 255.255.255.0

AllenRouter(config-if)#ip nat outside

AllenRouter(config-if)#no shutdown


AllenRouter(config)#router rip

AllenRouter(config-router)#version 2

AllenRouter(config-router)#no auto-summary

AllenRouter(config-router)#net 192.168.0.0

net宣告直连网段后,AllenPC1与AllenPC2均可Ping通路由器内网IP:192.168.0.1

AllenRouter(config-router)#default-information originate    给三层路由器分配一条默认路由出去


AllenRouter(config)#ip route 0.0.0.0 0.0.0.0 58.216.224.1   缺省路由,所有在路由表中没有办法匹配的数据包,都发向下一跳地址为58.216.224.1这个路由器


以下为允许192.168.10.0/24、192.168.20.0/24这三个网段可以通过NAT出去

AllenRouter(config)#access-list 1 permit 192.168.10.0 0.0.0.255   只允许IP为192.168.10.X网段的流量通过,其他的都不能通过

AllenRouter(config)#access-list 1 permit 192.168.20.0 0.0.0.255   只允许IP为192.168.20.X网段的流量通过,其他的都不能通过

AllenRouter(config)#ip nat inside source list 1 interface gigabitEthernet 0/1 overload


最后路由器和交换都要保存,命令为Router#copy running-config startup-config